Could not start project in new interactive mode

Kirill Zaborsky qrilka at
Wed Apr 18 09:38:58 BST 2012

Thanks a lot, Chris.
Looks like it works now, the main problem appeared to be with updated cabal
(cabal configure was needed).
But sometimes it fails, a couple of times I received the following message:

error in process filter: Symbol's value as variable is void:

and REPL was readonly.
Is it possible that the order of commands may play role here?

And 1 more question - are there any key combinations for REPL history? I
old interactive mode I used C+Up/C+Down sometimes is there anything similar?

Kind regards,
Kirill Zaborsky

2012/4/18 Christopher Done <chrisdone at>

> On 18 April 2012 07:42, Kirill Zaborsky <qrilka at> wrote:
> > I'm trying to setup new interactive mode, I use examples/init.el and
> when I
> > start new project (after hitting F5) I get message
> > The Haskell process `xlsx-parser' has died. Restart? (y or n)
> > and 'y' option does not work.
> > Messages buffer does not show up anyting more than that.
> > Is it possible to find out what goes wrong?
> > I run Emacs 23.2.1 on Ubuntu Natty and GHC 7.0.4
> In that case you must have cabal-dev enabled:
>  '(haskell-process-type 'cabal-dev)
> If you don't have cabal-dev it'll fail. Change this to
>  '(haskell-process-type 'ghci)
> If it ever breaks, you can always look in the *haskell-process-log*
> buffer which shows what was actually sent to/from the piped process.
> Does that solve your problem?
> Ciao!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Haskellmode-emacs mailing list