[haskell-llvm] GHCi with LLVM-2.8

Henning Thielemann lemming at henning-thielemann.de
Sun Oct 10 11:00:11 EDT 2010

When I tried to start LLVM examples from GHCi, it complained about
missing libLLVM-2.8rc.so. Then I ran

llvm-2.8> ./configure --enable-shared   # I hope that's the right option
llvm-2.8> make
llvm-2.8> make install

and then when running in GHCi I got

Prelude> :load DotProd.hs
Ok, modules loaded: DotProd.
Prelude DotProd> main
Loading package syb- ... linking ... done.
Loading package base- ... linking ... done.
Loading package type-level-0.2.4 ... linking ... done.
Loading package llvm- ... linking ... <interactive>:
unknown symbol `LLVMInitializeMSILTargetInfo'
ghc: unable to load package `llvm-'

Even worse, the statically linked program does no longer work:

thielema at euler:~/programming/haskell/llvm/examples> DotProd.exe
Two passes with the same argument (-preverify) attempted to be registered!

Any idea, what I did wrong?

More information about the Haskell-llvm mailing list